Установка GIT в Debian/Ubuntu (перевод)

В большинстве систем основанных на Debian/Ubuntu, GIT может быть установлен из программного репозитория как пакет. Основной пакет Git называется git-core, пакет документации — git-doc.

Остальные пакеты:

git-arch, git-cvs, git-svn
Если вам требуется переместить проект из Arch, CVS,  или Subversion в Git , то установите один из этих пакетов.
git-gui, gitk, gitweb
Если вы предпочитаете просматривать ваши репозитории в графическом приложении или браузере, то установите то что вам нужно. git-gui это Tcl/Tk-основанный графический интерфейс для Git; gitk другой браузер Git написанный на Tcl/Tk но уделяющий больше внимания истории проекта. gitweb написан на Perl и позволяет просматривать репозиторий Git в окне браузера.
git-email
Простой компонент позволяющий отправлять Git патчи через электронную почту. Такое практикуется в некоторых проектах.
git-daemon-run
Чтобы сделать общедоступным ваш репозиторий — установите этот пакет. Он устанавливает демона в систему который позволяет вам открывать репозиторий для анонимного скачивания.

В виду того что дистрибутивы и репозитории огромные, лучшим решением для вас будет выполнить поиск по своему программному репозиторию на наличие Git-пакетов. git-doc и git-email настоятельно рекомендуемо.

ВНИМАНИЕ.

Debian и Ubuntu предоставляет пакет git, но это не часть программы Git позволяющей управлять версиями программного обеспечения рассматриваемого в этом посте. git это абсолютно другая программа название пакета которой расшифровывается как GNU Interactive Tools. Будьте осторожны и не перепутайте название этого пакета с тем который здесь рассматривается!

Команда установки пакетов Git с помощью apt-get запускаемого от root:

Всё. Теперь у вас установлен Git ;)

Автор: Mirivlad

Скромный труженик консоли и окошек.

Комментарии:

Установка GIT в Debian/Ubuntu (перевод): 6 комментариев

  1. Доброго времени суток, подскажите пожалуйста в чем может быть причина тормозов redmine при входе по локалке? Страница в браузере очень долго загружается, на сервере все нормально.

      1. Mongrel не устанавливал, есть только Redmine и Apache2

        1. ну еще как вариант — добавить нативную поддержку мускула.

          aptitude install libmysqld-dev

          gem install mysql

          1. Спасибо, попробую, но кажется этот совет находил и на убунту оно не работает.

Комментарии запрещены.